Welcome to our support

 I've set up 6 schedules to export/email at specific intervals.  I had set some of them to send out on the 1st of the month at 8am.  I checked this morning and they had not exported/emailed at that time, so I had to manually export them.  Is there a step I'm missing that will allow these to send automatically?


Crystal Delivery Pro - Version 10.5.6


Time Zone: EDT (so it shouldve worked in time zone or UTC if it goes off of that)


1 person has this problem

It is possible that there was some sort of of issue with the export related to permissions.  Please check out the following solution article here on domain permissions for Pro.  This most likely is your issue.

John, thanks for your reply.  It was running on a local system account, so I moved it over to my account.  The export isn't running automatically still.


I can manually run the export all the time and it e-mails just fine, its just something is stopping it from auto-exporting (and e-mailing).


Are there logs anywhere where I can see if it is permissions? I would think a domain permission issue would also stop it from being manually run..

Log Instructions:

The Service Log file is located in the below directory:

C:\Program Files (x86)\Crystal Delivery\LogFile.txt


If you would like to submit the log file via support ticket, you can email it to support@ and I can take a look.

I have the same problem. Have just upgraded to standard version but now nothing runs. 

I don't seem to have a crystal process or a log file as mentioned above.

I have relaunched the application and re-created a number of reports in-case I missed something. 

Please advise? 

Jen,


Things that worked for me:


1) Moving the report I'm running and the export file locally to wherever Crystal Delivery is running.  I ran a similar software years ago that bringing things that may have been on remote destinations local helped.

2) What was mentioned above, changing the service to use a dedicated account 

Thanks Jeff. I am not able to have a dedicated account unfortunately. I have previously got the reports to run on my own account. 

I have moved the original .rpt file to a folder within the Crystal Delivery location but this has not worked either. 
My question is why is there no task scheduled for Crystal Delivery to run? This may well be the reason it's not firing. 


Hi Jen,


The error logs for the Standard version are located here:

C:\Users\<<your user>>\AppData\Roaming\Crystal Delivery\error.log


If you would share that with me, I can get some insight to what the problem might be.


Jeff - has your issue be solved?  If you are running Crystal Delivery Pro, Mapped Drives are not supported on Pro, please make sure you use the full path such as \\myserver\path\to\report.rpt for your report and export destinations.


Best,


John

The scheduled running of reports has been spotty at best.   I had a job running (on Pro) just fine and assumed that I had sussed the scheduling of reports however after I added a bunch of reports the original (and all other) reports would not run/export as scheduled.  I can export the reports manually, but as on a schedule (which was a major reason for the purchase of Crystal Delivery Pro) not so much.


I am running the service under a defined administrative user.  The error I am getting is:

3/18/2019 9:30:00 AM: MyJob->Execute: Load report failed.

3/18/2019 9:30:00 AM: Job Executed - Report ID: 2


Any help would be much appreciated.


Thanks.

Was there a solution to this issue?  I am also seeing this problem at my end here. 

Login or Signup to post a comment